Problem with images when... Content-Disposition: inline

Jul 28, 2008 at 6:11 PM
First I want to thank you for your hard work.  Your code is very nicely done.

I am having a challenge with your MailSample form.  It doesn't "extract" an image when: Content-Disposition: inline

I believe what this mean is that the image in "embedded" in the body of the message.  Can you make it so that your demo form app will extract the inline image and handle it as an "attachment" so that when I click your "Get" button, it saves it like an attachment?

Thanks again,
Kevin C.

PS - This was a MMS email from a cell phone to an email address....

Here is the WireShark capture when I run  your app on the inline content email...


+OK <8375.1217264612@p3p5656-02.prod.phx3.gdg>
user foo@bar.com
+OK
pass blah_blah
+OK
Retr 8
+OK 30615 octets
Received: (qmail 30725 invoked from network); 23 Jul 2008 17:23:57 -0000
Received: from unknown (HELO pre-smtp08-02.prod.mesa1.sesfsdfar.net) ([10.0.19.108])
          (envelope-sender <904545454545@mms.att.net>)
          by smtp33.prod.mesa1.secureserver.net (qmail-1.03) with SMTP
          for <mobile@asdfasdf.com>; 23 Jul 2008 17:23:57 -0000
Received: (qmail 9496 invoked from network); 23 Jul 2008 17:23:22 -0000
Received: from atlmtaor42.cingularme.com ([66.102.165.7])
          (envelope-sender <9046454545@mms.att.net>)
          by pre-smtp08-02.prod.mesa1.Zcr.net (qmail-ldap-1.03) with SMTP
          for <mobile@asdf.com>; 23 Jul 2008 17:23:21 -0000
X-Mms-MMS-Version: 16
Date: Wed, 23 Jul 2008 12:24:13 -0500
X-Nokia-Ag-Internal: ; smiltype=true; internaldate=1216833853002
Content-Type: multipart/mixed;  boundary="----=_Part_19615207_12540368.1216833853007"
X-Mms-Delivery-Report: 1
Received: from schagw02 ([209.183.32.189]) by atlmtaow02.cingularme.com (InterMail vM.6.01.04.00 201-2131-118-20041027) with ESMTP id 20080723172319.ORT6944.atlmtaow02.cingularme.com@schagw02> for <mobile@muasdf.com>; Wed, 23 Jul 2008 13:23:19 -0400
X-Mms-Transaction-ID: E13067B1CD9715
From: <90445454545@mms.att.net>
To: mobile@asdfasdf.com
X-Mms-Message-Class: 0
X-Mms-Read-Reply: 1
Mime-Version: 1.0
Message-ID: <10593438.1245454507.JavaMail.wluser@schagw02>
X-Mms-Priority: 1
X-Mms-Message-Type: 0
Subject: Multimedia message
X-Nokia-Ag-Version: 2.0
X-Nonspam: Statistical 60%

------=_Part_19615207_12540368.1216833853007
Content-Type: image/jpeg
Content-Transfer-Encoding: base64
Content-Location: Image_13.jpg
Content-Disposition: inline

/9j/4AAQSkZJRgABAQAAAQABAAD/2wCEAAoHBwgHBgoICAgLCgoLDhgQDg0NDh0VFhEYIx8lJCIf
IiEmKzcvJik0KSEiMEExNDk7Pj4+JS5ESUM8SDc9PjsBCgsLDg0OHBAQHDsoIig7Ozs7Ozs7Ozs7
Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7Ozs7O//AABEIAeACgAMBIgACEQED
......
...[trimed]...
......

------=_Part_19615207_12540368.1216833853007--





.


Coordinator
Aug 11, 2008 at 7:36 AM
Thank you for your post and comment.
I notice this discussion post yesterday,excuse me too late reply.
I modified Sample app with your requirement.
I hope this meet your requirement.

regard.

Nov 5, 2008 at 6:43 PM
Thanks!  Will try it out again soon.
Nov 6, 2008 at 10:10 PM
Edited Nov 6, 2008 at 10:31 PM
It seems standard attachments (as images) are broken now. 

:(

Edit:  I believe this happens when there is no body text at all. 

The attachment was sent via a phone, with only a subject and attachment.
Coordinator
Nov 10, 2008 at 2:30 AM
I checked what you pointed.
But in my enviroment,only a subject and attachment mail could receive correctly.

Please show me the text data of the mail,such as...
+OK <8375.1217264612@p3p5656-02.prod.phx3.gdg>
user foo@bar.com
+OK
pass blah_blah
+OK
Retr 8
+OK 30615 octets
Received: (qmail 30725 invoked from network); 23 Jul 2008 17:23:57 -0000
Received: from unknown (HELO pre-smtp08-02.prod.mesa1.sesfsdfar.net) ([10.0.19.108])
...

I want to debug with it.